请选择 进入手机版 | 继续访问电脑版
查看: 1325|回复: 3

[求助(已解决)] VPN L2TP 不能使用SS

[复制链接]

5

主题

18

帖子

193

积分

烽火狼烟

Rank: 3Rank: 3Rank: 3

积分
193
发表于 2017-3-2 15:39:07 | 显示全部楼层 |阅读模式
按照官网的手册我建了一个L2TP的VPN连家里,也成功了,现在的问题是连上VPN后内网和外网访问正常,但是不能科学上网了,我在家里连内网一切正常,在外面连VPN回去后就翻不了QIANG,这是我的VPN的配置,求解。

https://help.ubnt.com/hc/en-us/articles/204959404-EdgeRouter-Set-up-L2TP-over-IPsec-VPN-server



ubnt@ubnt# show vpn
ipsec {
     auto-firewall-nat-exclude enable
}
l2tp {
     remote-access {
         authentication {
             local-users {
                 username waaa {
                     password 123456
                 }
             }
             mode local
         }
         client-ip-pool {
             start 192.168.1.101
             stop 192.168.1.109
         }
         ipsec-settings {
             authentication {
                 mode pre-shared-secret
                 pre-shared-secret 28kr
             }
             ike-lifetime 3600
         }
         outside-address 0.0.0.0
     }
}
回复

使用道具 举报

5

主题

18

帖子

193

积分

烽火狼烟

Rank: 3Rank: 3Rank: 3

积分
193
 楼主| 发表于 2017-3-5 15:23:57 | 显示全部楼层
好吧,我是搬运工,自己找到了解决办法,参考下面的文章

https://community.ubnt.com/t5/EdgeMAX/EdgeRouter-DNS-and-VPN-connections/td-p/612815

方法如下
1. 启用DNS转发 (把x.x.x.x改成你的内网地址,我这里是192.168.1.2)
  1. configure
  2. configure
  3. set service dns forwarding options "listen-address=x.x.x.x"
  4. commit
  5. save
复制代码
2. 给VPN服务器加上DNS服务器(同上,我也里是192。168.1.2)
  1. configure
  2. set vpn pptp remote-access dns-servers server-1 192.168.1.2
  3. commit
  4. save
复制代码
附上我的修改后的VPN配置
  1. ubnt@ubnt# show vpn
  2. ipsec {
  3.      auto-firewall-nat-exclude enable
  4. }
  5. l2tp {
  6.      remote-access {
  7.          authentication {
  8.              local-users {
  9.                  username xxxx {
  10.                      password xxxx
  11.                  }
  12.              }
  13.              mode local
  14.          }
  15.          client-ip-pool {
  16.              start 192.168.1.101
  17.              stop 192.168.1.110
  18.          }
  19.          dns-servers {
  20.              server-1 192.168.1.2
  21.          }
  22.          ipsec-settings {
  23.              authentication {
  24.                  mode pre-shared-secret
  25.                  pre-shared-secret xxxx
  26.              }
  27.              ike-lifetime 3600
  28.          }
  29.          outside-address 0.0.0.0
  30.      }
  31. }
复制代码
回复 支持 1 反对 0

使用道具 举报

41

主题

452

帖子

1683

积分

有线传输

Rank: 5

积分
1683
发表于 2018-3-27 16:17:10 | 显示全部楼层
这个怎么指定不走主路由IP呢。
我是一台LEDE做旁路跑服务,想指定L2tp进来的主机也走旁路走。
回复 支持 反对

使用道具 举报

1

主题

8

帖子

45

积分

口耳相传

Rank: 1

积分
45
发表于 7 天前 | 显示全部楼层
按照您的设置,我的VPN也可以科学上网了,但是每次重启路由还是不能科学上网,国内的也上不去,必须得从新配置一遍DNS转发才行,查看配置表里面的参数都在,但是必须得在执行一遍才能好用,这是怎么回事啊?
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

优倍快网络技术咨询(上海)有限公司 沪ICP备13034452

© ubnt.com.cn All Rights Reserved.本站发布的所有内容,未经许可,不得转载.

快速回复 返回顶部 返回列表